HTML5: Verifica correttezza del codice fiscale in un form
10 settembre 2015
Un risorsa per centrare box html
3 novembre 2015
Mostra tutto

xampp

Finalmente è arrivato il mio turno per aggiornare Windows 10.

In realtà ero abbastanza soddisfatto di Windows 7 (di passare a Windows 8 non ci ho mai pensato), ma il mondo si evolve e non posso stare fermo con le mani nelle mani.

Poi Windows 10 sembrava non avere quell’interfaccia a quadrettoni che tanto non mi piace in Windows 8 (in realtà qualcosa c’è ancora, ma molto più piccola e sopportabile).

Così ieri ho preso il coraggio a quattro mani ed ho aggiornato il sistema operativo.

Al primo avvio del nuovo Windows tutto sembrava andare per il verso giusto: a parte un leggero rallentamento, tutto apparentemente funziona.

Provo ad avviare XAMPP ed Apache non parte; evidentemente qualcosa occupa la porta 80.

In questi casi il massimo indiziato e Skype; faccio prima il logout e poi lo chiudo del tutto: niente da fare.

Cercando su google trovo una risposta sull’onnipresente Stack Overflow: pare che Windows 10 installi una parte di IIS (il server web di Microsoft) ed è lui che occupa la porta 80.

cortanaIl resto del tempo l’ho passato a capire come disattivarlo …

Prima chiedo alla mia nuova amica Cortana dove posso trovare Programmi e Funzionalità e lo lancio (ho già nostalgia del vecchio Pannello di controllo)

qui, clicco sulla sinistra sul link Attivazione o disattivazione delle funzionalità di Windows, finchè non trovo nell’elenco Servizi WEB e disattivo tutto per sicurezza.

Risulta necessario riavviare il sistema, ma dopo Apache di XAMPP parte senza problemi.

FunzionalitaWindows

8 Comments

  1. Bruno ha detto:

    In effetti ho avuto lo stesso problema ma me ne sono accorto solo ora. Provo il suggerimento poi posterò i risultati.

  2. Bruno ha detto:

    fatto tutte le prove che ho trovato sul web ma senza risultati. Sotto Windows 10, installato pulito cioè cancellando il 7 ma versione 32bit nessun problema, quindi evidentemente dipende dalla versione a 64bit aggiornata da Windows seven

    • Giorgio Mancuso ha detto:

      Mi è capitato una volta che il sottosistema web a 32 bit non volesse saperne di funzionare: In quel caso, tutte le applicazioni a 64 bit (browser, sistemi di posta ecc) funzionavano correttamente mentre le applicazioni a 32 bit non ne volevano sapere di connettersi ad internet. Alla fine ho dovuto arrendermi e reinstallare Windows 10

      • Bruno ha detto:

        Innanzitutto buon natale, poi posso dirti che in effetti rifacendo una installazione pulita di Windows 10 sia a 32 che a 64 bit funziona senza problemi. Le ho provate tutte e due quindi confermo per esperienza personale.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *